Сети. Лаба 4. OSPF

Экспериментируем с мультиюзер-интерфейсом пакет трейсера

http://files.psu.ru/index.php/files/get/Iv5UlhJ8YA/psu-lab4-ospf-multius...

http://files.psu.ru/index.php/files/get/A0lvJI8x9e/psu-lab4-ospf-multius...

Протокол динамической маршрутизации OSPF. Редистрибьюция

OSPF - Open Shortest Path First («открывать сначала кратчайшие маршруты») – это протокол динамической внутренней маршрутизации, являющийся открытым стандартом. Поддержка протокола OSPF реализована на оборудовании различных производителей.
Особенности протокола:
- позволяет разделить автономную систему на зоны (area);
- минимизирует трафик с обновлениями маршрутов;
- хорошо масштабируется благодаря иерархии зон;
- поддерживает VLSM/CIDR (маски переменной длины, бесклассовая маршрутизация);
- не ограничивает число хопов до удаленных сетей;
- основывается на пропускной способности в качестве метрики;
- использует алгоритм Дикстры для вычисления кратчайшего маршрута;
- допускает работы с оборудованием различных производителей.

OSPF позволяет выделить в сети логические зоны и выстроить их в иерархию – каждая зона объединяет несколько маршрутизаторов и подключена к корневой зоне – area 0. Для определенности в дальнейшем будем считать, что наша сеть состоит всего из одной корневой зоны.
OSPF использует в качестве метрики стоимость маршрута. В таблицу маршрутизации попадет маршрут с минимальной стоимостью. Стоимость для конкретного интерфейса рассчитывается по формуле (108 /скорость интерфейса в bps). Стоимость маршрута до конкретной сети вычисляется как сумма стоимостей всех интерфейсов по ходу маршрута.
Маршрутизаторы, участвующие в протоколе OSPF и подключенные к общей сети, формируют связи. В дальнейшем, при изменениях в состоянии подключений, соседи обмениваются анонсами произошедших изменений. Основываясь на полученных анонсах, каждый конкретный маршрутизатор строит базу данных топологии сети и вычисляет стоимости всех соединений. Далее, по алгоритму Дикстры маршрутизатор рассчитывает маршруты с минимальной стоимостью каждой сети. Кратчайшие маршруты пополняют таблицу маршрутизации.
Для запуска OSPF на маршрутизаторее надо дать соответствующую команду, а затем настроить зоны.
Пример:

LAB(config)# router ospf 234

Данная команда активирует OSPF процесс с номером 234. В общем случае на устройстве можно запустить несколько независимых процессов маршрутизации, для каждого необходимо назначить номер. Номер имеет локальное значение и не обязан совпадать на всех маршрутизаторах. Номера могут иметь значения от 1 до 65535.
После запуска процесса OSPF, необходимо перечислить сети, участвующие в OSPF, подключенные к данному маршрутизатору и зоны, к которым относятся сети (у нас - area 0). Вместо маски сети указывается шаблон (wildcart). Шаблон равен маске, в которой значения битов инвертированы. В процессе OSPF будут участвовать интерфейсы, к которым подключены эти сети.
Пример запуска процесса номер 123 и добавление нескольких сетей:

LAB# conf t
LAB(config)# router ospf 123
LAB(config-router)# network 192.168.10.8 0.0.0.3 area 0
LAB(config-router)# network 192.168.10.80 0.0.0.15 area 0
LAB(config-router)# network 192.168.10.64 0.0.0.15 area 0

Маршрутизатор пробует установить соседство по OSPF через определенные интервалы времени - «hello-interval». Если в течение определенного интервала сосед не отвечает – соседство удаляется - это «dead-interval». На соседних маршрутизаторах эти значения должны совпадать, иначе соседство не устанавливается.
Интервалы прописываются на интерфейсе, например так:
interface FastEthernet0/0
ip ospf hello-interval 5
ip ospf dead-interval 10
Чтобы просмотреть маршрутизаторы, с которыми OSPF установил соседство, используется команда:
sh ip ospf nei

После внесения изменений в конфигурацию OSPF, необходимо перезапустить процесс. Для этого используется команда:
clear ip ospf process

Другой вариант – перезагрузить маршрутизатор.
Если на маршрутизаторе настроена статическая маршрутизация до некоторых сетей, и требуется включать эти маршруты в сообщения OSPF, используется команда редистрибьюции. Редистрибьюция также используется для передачи информации между разными протоколами маршрутизации на маршрутизаторе.
Пример:
LAB# conf t
LAB(config)# router ospf 123
LAB(config-router)# redistribute static

В выводе команды sh ip route, маршруты, полученные по OSPF обозначаются буквой “O”:

MANAGERS#sh ip route
10.0.0.0/24 is subnetted, 10 subnets
O 10.1.1.0 [110/65] via 10.1.4.1, 01:18:03, Serial0/2/0
O 10.1.2.0 [110/128] via 10.1.4.1, 01:18:03, Serial0/2/0
O 10.1.3.0 [110/128] via 10.1.4.1, 01:18:03, Serial0/2/0
C 10.1.4.0 is directly connected, Serial0/2/0
O 10.1.5.0 [110/128] via 10.1.4.1, 01:18:03, Serial0/2/0
O 10.1.6.0 [110/129] via 10.1.4.1, 01:18:03, Serial0/2/0
O 10.1.7.0 [110/129] via 10.1.4.1, 01:18:03, Serial0/2/0
C 10.1.9.0 is directly connected, FastEthernet0/0
O 10.1.10.0 [110/129] via 10.1.4.1, 01:18:03, Serial0/2/0
O 10.1.11.0 [110/129] via 10.1.4.1, 01:18:03, Serial0/2/0
O E2 192.168.0.0/24 [110/20] via 10.1.4.1, 01:18:03, Serial0/2/0

При указании сетей в OSPF допускается суммаризация при помощи шаблона.
Например, четыре сети
192.168.14.0/24
192.168.32.0/24
192.168.1.0/24
192.168.0.0/24
можно суммаризировать шаблоном для краткой записи так:
192.168.0.0 0.0.255.255

DHCP-протокол позволяет назначать адреса клиентам динамически из заданного диапазона.
Пул адресов создается следующими командами:
ip dhcp pool <poolname>
network <network-ip> <mask>
default-router <gateway address>

Топология сети

Все представленные сети имеют маску класса С - 255.255.255.0.
Вместо Z использовать уникальный номер.
Задача:
Необходимо настроить маршрутизацию в вашей сети по протоколу OSPF. Клиентам на компьютеры выдавать адреса с ближайшего маршрутизатора по DHCP.
Подключиться через multiuser Cloud к маршрутизатору RouteAggregator и запустить OSPF маршрутизацию между всеми сетями.

Задание 1:
1. Пропишите на маршрутизаторе BORDER, на внешнем интерфейсе уникальный мак-адрес и ip-адрес из сети 10.10.10.0/24.
2. Пропишите на внутреннем интерфейсе BORDER адрес из сети 10.10.Z.0/24.
3. Задайте ip адреса на маршрутизаторе CORE и создайте dhcp-пул для клиентов. Убедитесь, что клиенты получили адреса.

Задание 2:
1. Запустите на маршрутизаторах CORE и BORDER протокол OSPF.
2. Укажите в настройках OSPF адреса всех непосредственно подключенных к CORE и BORDER сетей.
3. Проверьте, что маршрутизатор установил соседство с соседями и принял маршруты.
4. Если маршруты не появились, перезапустите процесс OSPF, либо перезагрузите маршрутизатор.

Задание 3:
1. Зайдите в multiuser облако, укажите Peer Address – комп преподавателя, peer port – 38000, Peer Name – уникальное имя, Password – ciscocisco.
2. Проверьте, что маршрутизаторы установили соседство и обменялись маршрутами.
3. Если маршруты не появились, перезапустите процессы OSPF, либо перезагрузите маршрутизаторы.

Комментарии